*

Evan Reiter

  • Training Administrator
  • 6263
The Forums Are Back!
« on: February 19, 2011, 09:27:21 am »
I sent out a long e-mail recently (full text below) describing what's been going on with the forums and the website. As I explain in the e-mail, we were forced to transition our forums from an MS SQL database to MySQL. This process was incredibly challenging, especially without using any commercial/payware software. I am happy to say that *I think* all of the users, forums, and posts from our previous database have been transitioned. However, there may be some posts that are missing; there could also be some posts that do not display as intended. Each user will also have to go back and reset signatures and avatars (sorry!)

I am confident this will be the last time we have to transition the forums anywhere. Now that we are securely on MySQL, it should be easy to transfer the forum to any other ISP because pretty much every ISP supports php in non-Windows environments (whereas many do not support php for MS SQL).

You may see some topics that have some strange-looking text at the top. As long as the text in those posts appears properly, I am not concerned. However, if you do find posts that are clearly irrelevant and should be deleted, please let me know.

----- Text from e-mail to be sent out Saturday, February 19 ------

Many of you are aware of the issues we have been having with our website. Since January 17, parts of the site—including (at separate times) the forums, main website, and e-mail system—have been unavailable. Phil, Bill, and I have been working to try to fix these issues as quickly as possible, and without the loss of any data or user accounts.

I am happy to say that we have mostly accomplished this. A full description of what has happened over the past month for those interested in reading through it is included below. However, for everyone, please note the following important information.

1/ Unless you received an e-mail otherwise, you should be able to login to your account on both the forums and website. If you are not able to login, please check your e-mail for instructions. If there is no information there, please contact us for assistance.

2/ Some pages of the website, including “Downloads”, “Event Scenery”, and “Image Gallery” will remain unavailable for a few weeks.

3/ Migrating a website is (as we recently found out) a rather complex process. There will likely be broken links in a number of places that we have forgotten to change. Please use the “Broken Links” thread on the forums or e-mail us directly to report any links you find that do not work.

I would also like to thank everyone for the immense patience you have shown. Administrating a website and forum system as complex as BVA’s should be a full-time job!

In order to prevent similar scenarios, we have transitioned the website to a much more reliable ISP with much better support. We have also switched the forum database structure to a more widely-used system. While I know issues will continue in the future, I cannot imagine that we will see anything like the issues we have over this month again.

The remainder of this e-mail explains what has occurred over the past month in terms of attempting to restore the forums, website, and e-mail system. This information is provided for your interest only; please ignore this section unless you are curious to know what we have been going through for the past month. The steps we took are presented in a brief timeline format. Provider names have been disguised. The ISP we have used since 2006 is referred to as “Provider A”; our new provider is referred to as “current provider”.

I have written the timeline below not to show you what happened but to give you an idea of the immense contribution that Bill and Phil have made to our community through their support. The tireless efforts of the many people that keep BVA in the air are a constant inspiration.

January 17: We discovered that e-mails from the website (including password reminders) were not being sent. When I would try to send an e-mail from the website, I would get a confirmation and positive report, but no e-mail would actually appear. No error messages were displayed.

January 17: We posted support tickets with Provider A and Google (our e-mail is sent through Google). We were able to confirm the issue was at Provider A very quickly. As of February 19, the support ticket totals 19 pages. No progress has been made. By page 18 (a week ago), they admitted it was their fault.

January 21: The forums go offline with an error message that states: “General Error; could not get style data”. phpBB support forums indicate the issue has to do with file permissions. We ask Provider A to reset file permissions but they claim this is impossible.

January 22: Recognizing that the solution to issue with the forums rests in the hands of Provider A, we open an account with Provider B and begin to transfer files and database structures to this provider. Simultaneously, we called Provider A several times, establishing a relationship with one of the operational managers there. We made no progress.

January 23: The forums and a basic copy of our website are online through Provider B. We re-link the forums to this provider and re-open the forums. E-mails sent through the website on Provider B using the same SMTP settings go through.

January 23: BVA’s website (on Provider A) goes down. I call Provider A who claims the issue is a “permissions problem that should be resolved in 30 minutes”. A few hours later, the website returns and BVA’s original forums return as well. We spent the entire weekend fixing a problem that was in fact a permissions issue that could have been fixed by Provider A.

January 23-27: We perform more than 4 years of upgrades on the website and forums that we could not do with Provider A.

January 27: Provider B is a temporary host that offers very little space and bandwidth. While we were glad to host the forums there for a short period, it was a temporary solution. Since no progress had been made with either e-mail from Provider A, we opened an account with Provider C.

January 28: While opening the account with Provider C, they confirm that we can migrate all our files and database structures to their servers.

January 28-31: Provider C’s control panel does not allow us to migrate a backup copy of our database to their servers. We attempt a workaround method described on their knowledgebase that fails. After spending several hours uploading more than 10 GB of files, a call to Provider C’s support confirms there is no other way to migrate this database. We close the account with Provider C.

February 1-5: We continue to go back and forth with Provider A over the e-mail issue. In the interim, I use Provider B’s website to send Event Reminder e-mails and manually inform new members that they have been approved. Since the website’s Password Reminder feature uses this e-mail system, several users contact me to request password changes.

February 3: In an attempt to speed up our website, Provider B performs an upgrade to our account. This disables the forums and website. We go back and forth through support tickets but they refuse to provide any additional support. Later in the week, we closed the account with Provider B.

February 4: Since the forums with Provider A had come back online and Provider B’s forums went down, we wanted to use Provider A for the forums again. When we tried to re-activate these forums, all the posts disappeared. The topics are still in place, but none of the actual posts appear.

February 6: We open an account with our current provider. This provider is billed as an expert in the types of software used by our website and forums, claims to have excellent support, and was recommend by the developer of our website’s content management system.

February 7-9: We upload the files and database to our current provider.

February 11: With the help of our current provider’s support, a copy of the website is installed and works. E-mail does not work. The forums display php error messages or simply do not display.

February 11-13: Our current provider and I work on getting the forums online. Our brand of forums is not intended to run on the type of database we have been using in the past. Our ISP recommends that we switch to a MySQL database (from MSSQL), but this process is complex and not supported. They do not know of a way that data from MSSQL can be transferred to an installation of the forums on MySQL.

February 13-15: We are able to finally get the forums and website online. However, the infrastructure in place at this new provider was not designed to run our forums on MSSQL. The forums are slow to load. It is impossible to make changes to settings.

February 18: We decide to try to migrate the database elements from MSSQL to a MySQL version of the forums. We discover we can migrate files by individually accessing database elements (users, posts, subjects, etc. are stored in separate files), downloading them, and re-uploading them to the new database. The forums and topics display okay, but the actual posts do not import.

February 19: Bill, through an ingenious parsing of the XML file, is able to create a file that the MySQL reader can accept. Most of the posts, along with the users and groups, appear on the new forums.

February 19: Domain name transfer initiated.


Evan Reiter
Training Administrator

Re: The Forums Are Back!
« Reply #1 on: February 20, 2011, 09:17:51 am »
Finally! Good work Evan and the rest of the admin team for your hard work and dedication to solving this problem! Mochahagtdi!
Center Controller, Canadian private pilot (PPL SEL)

——————

My Flickr  "Which is more useful, the Sun or the Moon? . . . The Moon is the more useful, since it gives u

*

chuck

Re: The Forums Are Back!
« Reply #2 on: February 20, 2011, 03:48:25 pm »
awesome awesome.  thank you guys for the efforts!

Re: The Forums Are Back!
« Reply #3 on: February 20, 2011, 04:15:44 pm »
Thanks for all of your hard work!
[img]http://staticthumbs3.freewebs.com.s3-website-us-east-1.amazonaws.com/THUMBS/11/4a/114a5b99a9a573df9d7fad4df278c93d.JPG[img]

Re: The Forums Are Back!
« Reply #4 on: February 20, 2011, 05:24:48 pm »
Thank you so much to all your efforts... Phil, Bill, Evan and all you webheros!!!  ;)
Gilles | CYUL | PRP Coach | Founder of the "TANGO SQUADRON" - BVA member since July 31st 2008


Re: The Forums Are Back!
« Reply #5 on: February 21, 2011, 06:39:23 pm »
Wow thanks for your work.